FI and idle issues

Discussion in 'Tech Talk' started by Elusive1, Feb 25, 2019.

  1. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    Hey all I have 3 issues sorry for long read. #1 of late my m109R has been idling higher than normal, it slowly drops back to normal when I come to a stop (not always though) and on the weekend on way home it was idling at 1500RPM....my tuner said he thinks 99% it is the ISC valve and has a small bit of grit or dirt in it.

    dealer said to remove, clean and check would run about 2-2.5 hours and cost $250 including hooking bike up and checking diagnostics, wondering if anyone knows how much a new one is or if my cleaned one is fine or has anyone removed and cleaned theirs themselves?

    #2 also I had FI come up on my odometer, but no actual FI light on speedo cluster, what does this mean? bike started fine, haven't seen it since.

    #3 also one other question, do our bikes have any form of adjustment in brakes, as in rear brake or a bias set up? my rear locks up and I'm not putting heaps of pressure on peddle yet a few times I've braked and had to just hold on and enjoy the slide as the back locks up?

    for reference bike is 2012 model with just over 12,000km
  2. Hulk
    Offline

    Hulk Supporter Member

    Joined:
    Aug 17, 2014
    Messages:
    6,552
    Likes Received:
    8,128
    Location:
    Western Suburbs Melbourne
    Not sure about 1 or 2 but 3 is an easy fix...use less foot and more right hand....I hardly use my rear brake at all.
    Sneikz and ottafish like this.
  3. Spanners
    Offline

    Spanners Member

    Joined:
    Dec 21, 2011
    Messages:
    3,212
    Likes Received:
    2,894
    Location:
    Penrith
    Check your Throttle position sensor
    [​IMG]

    Sent from my SM-G955F using Tapatalk
  4. steve M109 RZ
    Offline

    steve M109 RZ Supporter Member

    Joined:
    Dec 1, 2011
    Messages:
    3,652
    Likes Received:
    862
    Location:
    townsville
    #3 adjust your rear brake peddle around a little so that you can apply your pressure as not to kick the rear.
  5. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    thanks Spanners, what is the special tool/mode select switch? I've never heard of that process you've posted I'm very intrigued.
    I completed the full service, oil, plugs, diff oil and cleaned filters etc and I cleaned the ISC valve with WD40 so hoping it may fix it, if not ill try what you've advised
  6. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    That the one? Red wire “special tool”

    [​IMG]
    Last edited: Mar 6, 2019
    Spanners and ottafish like this.
  7. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    Yaaaaaawn ..... can’t rush these things
    Hopper likes this.
  8. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    haha I know right! sorry have been flat out, I will try it tonight. Do I insert the wire with ignition on? or do I have bike off, insert wire then turn on? just don't want to wipe any error codes if that can happen.
  9. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    Fuck knows... at a guess I’d put the wire in then turn key on.
    ottafish likes this.
  10. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    i'd think so too, ill give it a crack tonight, cheers.
  11. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    Verdict? Ya didn’t Do it did ya? Lol
  12. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    Mabe he crossed wires ?
    [​IMG]
    Disco Turtle, Elusive1 and ottafish like this.
  13. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    OK so I did it and the readout is on the lower bar not the middle. I will adjust the TPS sensor , but am I right in thinking lower bar would mean lower idle, middle is right and higher bar higher idle? or is that not how it works? can't find info on it.
  14. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    Fuck knows just do what it says LOL
    Hulk likes this.
  15. Spanners
    Offline

    Spanners Member

    Joined:
    Dec 21, 2011
    Messages:
    3,212
    Likes Received:
    2,894
    Location:
    Penrith
    Not how it works.
    Tps out of range expected by the ecu means the idle speed could be erratic, stumble in the acceleration, rich or lean mixture throu the range

    Sent from my SM-G955F using Tapatalk
    Scotty likes this.
  16. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    ok guys sorry for long overdue update, I changed it to the centre and It seems to have fixed it, although only been on a short ride since. However I also accidentally undid the wrong screw to the other thing next to it (secondary throttle sensor?) which now I have to take bike to dealer and get them to dial it back in with their diagnostics/laptop or whatever they use as I want to make sure its running 100% right and having it sluggish, thanks for your help guys!
  17. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    she's booked in to the dealership tomorrow to have them look at the ISC, TPS and the
    Secondary TPS just to make sure its all sweet :) glad this will be over and hopefully they can find the fault and fix the idle issue.
  18. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,895
    Likes Received:
    4,652
    Location:
    NSW
    State:
    Nsw
    So you didn’t end up fixing it in the end ?
  19. Elusive1
    Offline

    Elusive1 Member

    Joined:
    Nov 2, 2016
    Messages:
    81
    Likes Received:
    61
    Location:
    SA
    State:
    SA
    nope thought I'd fixed it but still there and it doesn't happen all the time so hoping they can troubleshoot and find what it is.
  20. SeannesM109R
    Offline

    SeannesM109R Staff Member Moderator Supporter

    Joined:
    Dec 4, 2011
    Messages:
    7,990
    Likes Received:
    3,813
    Location:
    Outer space!
    Geez mate... Your asking a lot of the Stealer! Good luck...
    Hulk likes this.