Idle speed control valve

Discussion in 'Tech Talk' started by Paul Harris, Dec 5, 2018.

  1. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    I've taken my M90 to a Suzuki dealer as FI light on, isn't an O2 sensor issue as I'd originally been told by another mechanic. They're telling me it's Idle speed control,valve as it's code 40 - a new one should fix it - about $500 fitted...but that may not fix it - could need a new harness. The bike runs fine apart from popping back on decel and low idle when cold. Anyone else experienced this. I'm expecting this guy to charge me $1500 and not fix it...
  2. Griff
    Offline

    Griff Supporter Member

    Joined:
    Oct 27, 2015
    Messages:
    1,409
    Likes Received:
    1,674
    Location:
    Newcastle weekdays & Telegraph Point weekends.
    State:
    N.S.W.
    Buy the part and I''ll come help you install it one arvo
    Hopper likes this.
  3. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Thanks Griff - does it sound likely that this is the problem though. I've been told it wouldn't even run if it was the that? The part's $300
  4. Scotty
    Offline

    Scotty Member

    Joined:
    Oct 23, 2016
    Messages:
    2,415
    Likes Received:
    3,693
    Location:
    NSW
    State:
    Nsw
    Sounds like bullocks to me... is your dealers name Punjab ?
    Hulk likes this.
  5. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Nah...Chris
  6. Griff
    Offline

    Griff Supporter Member

    Joined:
    Oct 27, 2015
    Messages:
    1,409
    Likes Received:
    1,674
    Location:
    Newcastle weekdays & Telegraph Point weekends.
    State:
    N.S.W.
    Scotty's just trying ta be funny coz he knows I made a valid point in a previous post.

    Look, to be honest, he could be on to something with the wiring. My 109 had a phantom fault just after I got it and after weeks of searching and fucking around I discovered it was 2 pins in the main plug into the ECU had pushed out of their mount.
    Work told me today I have to go back out to Innamincka next week, and then Brissy the following week, then Perth for the 2 weeks over xmas. What are you doing tomorrow arvo?
  7. Spanners
    Offline

    Spanners Supporter Member

    Joined:
    Dec 21, 2011
    Messages:
    3,179
    Likes Received:
    2,827
    Location:
    Penrith
    The fact that the dealer says it "should fix it" means to me they did no testing other than read the code. Here's a link to an m90 manual you can download from my dropbox. Look up the code, there's a test procedure for the idle speed control valve. There's also a procedure to learn its base setting.

    https://www.dropbox.com/s/10uu0pil72080xr/Boulevard M90 Service Manual.pdf?dl=0

    Sent from my SM-G955F using Tapatalk
    Hulk, DERDY and SeannesM109R like this.
  8. DERDY
    Offline

    DERDY Staff Member Moderator

    Joined:
    Dec 17, 2011
    Messages:
    2,415
    Likes Received:
    2,845
    Location:
    melb
    State:
    Victoria
    Legend of a bloke...great stuff Spanners
    ottafish and TIK61 like this.
  9. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Hey thanks Griff but I had to take it to Cessnock - closest Suzuki dealer...so that's where it is til I can get back up there and retrieve it. I'm at work til 4 tomorrow so that's not gonna happen unfortunately.
  10. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Thanks mate - I'll call Chris Watson's tomorrow and run this by him before I get too committed.
  11. Griff
    Offline

    Griff Supporter Member

    Joined:
    Oct 27, 2015
    Messages:
    1,409
    Likes Received:
    1,674
    Location:
    Newcastle weekdays & Telegraph Point weekends.
    State:
    N.S.W.
    Bugger mate, all good. Hopefully you get to the bottom of this without it costing too much.
    If you can get your tank off and side covers, just check all of the plugs and wires at the ISCV and at the ECU. Look for any pinch points where the loom might be rubbing or damaged.
    Also - Kepp this in mind, it's a bit closer than Cesspit:
    http://www.suzukimotorcycles.com.au/dealers/nsw/maitland-motorcycles
  12. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Thanks mate - gave em a call - he's looking into it.