PCV - fault codes...

Discussion in 'Tech Talk' started by Paul Harris, Nov 27, 2018.

  1. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Hi
    I've had FI light on and got lots of different opinions about it - mainly O2 sensor issue. Tried 3 different O2 sensor eliminators and an O2 sensor, none of which helped. Spoke to another mechanic today who advised me to take out the PCV before I brought it in...might save me $220. Only two wires he said...

    Screen Shot 2018-11-27 at 4.46.54 PM.png

    but after tracing a number of branches off the PCV wiring and eventually managing to unplug them all there were five seperate plugs coming off this thing. I've got two plugs I don't know what to do with...

    Please help!

    Screen Shot 2018-11-27 at 4.48.52 PM.png
  2. JR
    Offline

    JR Staff Member Administrator Supporter

    Joined:
    Nov 30, 2011
    Messages:
    5,148
    Likes Received:
    5,662
    Location:
    Toolern Vale, Melbourne, Victoria
    State:
    VIC
    Aren't they the ones that plug onto your injectors ... ? ...........:dontknow:
  3. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Could be...I can't find corresponding plugs for them.
    Hopper likes this.
  4. Griff
    Offline

    Griff Supporter Member

    Joined:
    Oct 27, 2015
    Messages:
    1,409
    Likes Received:
    1,674
    Location:
    Newcastle weekdays & Telegraph Point weekends.
    State:
    N.S.W.
    Does it have 2 plugs - one into each injector, and 2 plugs - one into each of the stock injector plugs.
    Hopper likes this.
  5. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    I guess that could be right - 2 + 2 plugs and a yellow/white one
  6. Griff
    Offline

    Griff Supporter Member

    Joined:
    Oct 27, 2015
    Messages:
    1,409
    Likes Received:
    1,674
    Location:
    Newcastle weekdays & Telegraph Point weekends.
    State:
    N.S.W.
    I'm guessing Yellow/White = ground + ign power?
  7. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    I've calmed down...I'll go back and have another look :dorag:
    Hopper likes this.
  8. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Think I found where they go. There's a whirring sound - would that just be because I've got the tank off - fuel pump or something?


    Screen Shot 2018-11-28 at 1.58.50 PM.png
    Hopper likes this.
  9. DERDY
    Offline

    DERDY Staff Member Moderator

    Joined:
    Dec 17, 2011
    Messages:
    2,417
    Likes Received:
    2,847
    Location:
    melb
    State:
    Victoria
    No the fuel pump is in the tank, so if its off not connected....
  10. JR
    Offline

    JR Staff Member Administrator Supporter

    Joined:
    Nov 30, 2011
    Messages:
    5,148
    Likes Received:
    5,662
    Location:
    Toolern Vale, Melbourne, Victoria
    State:
    VIC
    They should plug onto the Injectors on the top of the engine ........
  11. Paul Harris
    Offline

    Paul Harris Member

    Joined:
    Jun 12, 2018
    Messages:
    25
    Likes Received:
    9
    State:
    NSW
    Running! Still got the C40 though...
  12. Spanners
    Online

    Spanners Supporter Member

    Joined:
    Dec 21, 2011
    Messages:
    3,179
    Likes Received:
    2,827
    Location:
    Penrith
    Manual says if you unplug the icv whilst ignition is on or too soon after switch off, you'll loose its saved value and cause this code. It then needs to be relearned

    Sent from my SM-G955F using Tapatalk